Jump to content

  • Images:

    I_gotta_rock
    • Collected from matrix deposited in the Chesapeake Bay by landslide. These shells are extremely fragile and are not to be found loose on the beach. Most disintegrated when I was working the matrix. This specimen was donated to the Delaware Museum of Natural History.

    Taxonomy

    Venus Clam

    Kingdom: Animalia
    Phylum: Mollusca
    Class: Bivalva
    Order: Veneridei
    Family: Ungulinidae
    Genus: Diplodonta
    Species: D. subvexa
    Author Citation (Conrad, 1838)

    Geological Time Scale

    Eon: Phanerozoic
    Era: Cenozoic
    Period: Neogene
    Epoch: Miocene

    Stratigraphy

    Choptank Formation
    Drum Cliff

    Biostratigraphy

    Shattuck Zone 17

    Provenance

    Collector: Heather Siple
    Date Collected: 07/03/2017
    Acquired by: Field Collection

    Dimensions

    Height: 12mm
    Diameter: 28mm

    Location

    St Leonard
    Calvert County
    Maryland
    United States

    Comments

    Collected from matrix deposited in the Chesapeake Bay by landslide. These shells are extremely fragile and are not to be found loose on the beach. Most disintegrated when I was working the matrix. This specimen was donated to the Delaware Museum of Natural History.



    User Feedback


    10 minutes ago, belemniten said:

    I dont see a picture :headscratch::headscratch:

    It's there, but very tiny. You have to click on it to blow it up to full screen. Alternatively you can switch to classic theme (at the bottom of the page).

    Share this comment


    Link to comment
    Share on other sites

    Odd. It has vanished for me as well in both themes, but I'm also on my tablet at the moment. I'll keep my eye on this and test this on the laptop later. Could be a temporary server or software glitch.

    Share this comment


    Link to comment
    Share on other sites
    I_gotta_rock

    Posted · Report

    3 hours ago, Kane said:

    Odd. It has vanished for me as well in both themes, but I'm also on my tablet at the moment. I'll keep my eye on this and test this on the laptop later. Could be a temporary server or software glitch.

    That was weird. I went into the editor and the files were listed, but they were definitely not showing. I deleted and reloaded them. Let's see if they stay.

     

    Share this comment


    Link to comment
    Share on other sites


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now


×